Portal Home > Knowledgebase > FAQ > Connection


Connection




Q. What do I need to connect to your services?
A. You need CCcam 2.0.9 or newer or Incubuscamd compatible box/device


Was this answer helpful?

Add to Favourites Add to Favourites    Print this Article Print this Article

Also Read
STB Model (Views: 668)
Spiderbox (Views: 654)
Skybox F5 (Views: 1055)
Reshare (Views: 1362)
Phisycal card (Views: 889)

Powered by WHMCompleteSolution

Contact

Testimonials

SSL Certificate
Webutation McAfee SECURE sites help keep you safe from identity theft, credit card fraud, spyware, spam, viruses and online scams